Upgrade to Ruby 2.6.5

Description

Upgrade to latest stable release of Ruby 2.6.

Testing

This includes updating the Elasticsearch gem to 6.1.0, so let’s do a quick test of filters and search for bookmarks and works, and also making sure the listings update if you add, edit, or delete a work or bookmark.

We also traditionally check if making a gift exchange, signing up for it, and running matching works properly.

Environment

None

Status

Assignee

james_

Reporter

james_

Roadmap

None

Priority

Medium

Affects versions

Fix versions

Components

AutomatedTests
BackEnd
Caching
FrontEnd
Parser
RichTextEditor
Utilities

Difficulty

Medium

Required Access Level

None

Epic Link

Milestone

Internal 0.9
Configure