Rename creators method in Works model

Description

In models/works.rb, we have a method named creators. It is the list of creators used for Elasticsearch indexing.

However, because of its ambiguous name, people understandably keep trying to use it for purposes for which it was not intended. Then reviewers like ticking instant and redsummernight have to say, hey, that doesn't do what you think it does, and all of this somehow ends up with Sarken updating multiple pull requests.

Please, let's change the f()%&!! name. redsummernight suggests indexed_creators.

Environment

None

Assignee

Unassigned

Reporter

Sarken

Roadmap

Works

Priority

Medium

Affects versions

Fix versions

None

Components

BackEnd

Difficulty

Easy

Required Access Level

None

Milestone

Internal 0.9
Configure